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Model Syllabus for Applications of Artificial Intelligence in consonance with 

Curriculum framework w.e.f. AY 2025-26 

 

1. Applicable to Botany, Zoology, Bio-Technology, Miro-Biology and other Life 

Sciences 

2. Applicable to Commerce and Management 

3. Applicable to History, Economics, Political Science, Linguistics, and any other 

Humanities 

4. Applicable to Mathematics, Physics, Chemistry and any other Mathematical 

Sciences 

5. Applicable to Computer Science, Data Science, Artificial Intelligence, Cognitive 

Systems, Data Analytics, Cloud Computing, Cyber Security and any other 

Computer Science Allied Streams 

 

COURSE STRUCTURE  

Year Semester Course Title of the Course 

No. of 

Hrs 

/Week 

No. of 

Credits 

I II 1 

Applications of Artificial Intelligence 3 3 

Applications of Artificial 

Intelligence-Practical 
2 1 

 
 

 

 

 

 

 
 

 

 

 

 
 

 



1. APPLICABLE TO BOTANY, ZOOLOGY, BIO-TECHNOLOGY, MIRO-

BIOLOGY AND OTHER LIFE SCIENCES 

SEMESTER-II 

COURSE 1: APPLICATIONS OF ARTIFICIAL INTELLIGENCE 

Theory                                             Credits: 3                                          3 hrs/week  

 

Course Objectives 

1. Provide a foundation in the AI ecosystem, including hardware, cloud, and edge platforms 

relevant to biological sciences. 

2. Familiarize students with different types of datasets and public repositories used in AI 

research. 

3. Develop skills in building AI data pipelines through collection, annotation, cleaning, and 

preprocessing. 

4. Explore real-world applications of AI in agriculture, ecology, zoology, and environmental 

sciences. 

5. Introduce AI-driven approaches in biotechnology and chemistry, such as genome 

sequencing, protein structure prediction, and drug discovery. 

 

Course Outcomes 

On successful completion of this course, students will be able to: 

1. Explain the role of AI hardware, edge devices, and cloud platforms in enabling applications 

in biological sciences. 

2. Differentiate data types and utilize public datasets relevant to AI in life sciences. 

3. Design and implement a conceptual AI data pipeline for solving biological problems. 

4. Apply AI techniques in case studies of agriculture, zoology, ecology, and environmental 

monitoring. 

5. Analyze the impact of AI in biotechnology and chemistry, particularly in genome 

sequencing, protein prediction, and drug discovery. 

 

 



Unit 1. Infrastructure and Platforms for Building Applications using AI 

Hardware used in building AI applications: Processors - CPU, GPU, TPU, NPU, Memory - 

RAM, VRAM, Storage - HDD, SSD 

Platforms for building applications using AI: Online platforms (Example - Google AutoML, 

H2O.ai, Teachable Machine or similar platforms - for practice only); Desktop (No-code/Low-

code) platforms (Orange Data Mining, KNIME, Weka, RapidMiner or similar tools - for practice 

only). 

 

Edge AI: Concept; Applications in daily life in devices like Refrigerators, Led Bulbs, Surveillance 

Cameras, Micro Ovens, Smart Cars/Scooters; Edge AI in smart Appliances 

 

Unit 2: Foundations of Data - Types, Ethics and Utility in Building Applications using AI 

Importance of data in building AI applications: Data as the fuel for AI, Role of big data in 

training AI models. 

Conceptual Foundations of Data: Data vs. Information vs. Knowledge. 

Structure of Data: Structured, Semi-Structured, and Unstructured Data. 

Modalities of Data: Text, Image, Audio, Video, Tabular, Time-Series, and Spatial Data. 

Formats of Data: Text Formats (CSV, JSON, XML), Image Formats (JPEG, GIF, PNG), 

Audio/Video (MP3, WAV, MP4, AVI). 

Data Repositories: Definition of public Datasets; Definition of private Datasets; Importance of 

Public Datasets, Popular Public Dataset Repositories (Example - Kaggle, Hugging Face Datasets, 

UCI Machine Learning Repository, Google Dataset Search or similar ones - for demonstration 

only), Dataset licensing and usage rights. 

Ethics, Privacy in Data Usage: Privacy concerns related to data usage; Regulations governing 

data usage - GDPR, HIPAA (Overview), Ethical use of data, Responsible AI data practices. 

 

Unit 3. The AI Data Pipeline: From Collection to Model Readiness 

The AI Data Pipeline: Stages and Components: Key Stages (Data Collection, Annotation, 

Preprocessing, Splitting, Feeding into AI Models 

Core Components: Ingestion, Storage, Processing, Validation, Delivery 



Data Collection Methods for AI: Manual Input (Surveys, forms, human-curated entries), Sensors 

& IoT Devices (Real-time data from physical environments), System Logs & Transactions, Web 

Scraping (Automated extraction from websites), APIs (Structured data access from external 

platforms) 

Data Annotation and Labelling: Definition & Importance; Annotation Methods: Manual 

Annotation, Automated Annotation; Types of Annotation: Classification, Bounding Boxes, 

Segmentation, Transcription, Named Entity Recognition (NER). 

Data Cleaning and Preprocessing: Importance of data cleaning; Understanding “Dirty” Data: 

Missing Values, Duplicates, Incorrect Formats, Outliers, Noise; Steps in Data Cleaning: Identify 

Issues, Handle Errors (Imputation, Removal), Validate Cleaned Data. 

Data Splitting: Splitting data into training set and test set. 

Data Transformation Techniques: Normalization, Transformation, Feature Engineering 

(Conceptual) 

 

Unit 4: AI in Biological Sciences 

AI in Botany & Agriculture: Plant disease detection via image recognition; Crop yield 

forecasting using climate and soil analytics; Precision agriculture: smart irrigation and fertilizer 

planning 

AI in Zoology, Ecology & Environmental Sciences: Wildlife monitoring: species ID from 

camera trap data; Aquatic systems: fish recognition and water quality modeling; Livestock health 

and disease prediction; Environmental tracking: forest cover and pollution analysis 

 

Unit 5: AI in BioTechnology and Bio-Chemistry 

Application of AI in Genome sequencing & gene function prediction; Using AI in Protein structure 

modeling (e.g., AlphaFold); AI for Drug discovery: virtual compound screening; Application of 

AI in Microbial classification & metagenomic profiling; Chemical reaction and material property 

prediction 

 

 

 

 



1. APPLICABLE TO BOTANY, ZOOLOGY, BIO-TECHNOLOGY, MIRO-

BIOLOGY AND OTHER LIFE SCIENCES 

SEMESTER-II 

COURSE 1: APPLICATIONS OF ARTIFICIAL INTELLIGENCE 

Practical                                             Credits: 1                                          2 hrs/week  

 

Suggested Lab Practicals (No Coding) 

Lab 1 - Exploring Public Datasets (Orange Data Mining) 

● Visit a public repository (Kaggle, UCI, data.gov.in) 

● Download a dataset (e.g., rainfall data, literacy rates, or traffic accident statistics) 

● Procedure: 

1. Open Orange → Add File widget → Load a CSV (e.g., Titanic dataset). 

2. Connect to Data Table → View rows/columns. 

3. Connect to Data Info → Check attributes, data types. 

4. View in Data Table and Distributions widget. 

● Observation: Note numeric, categorical, missing values. 

● Outcome: Students understand structured data format in CSV. 

  

Lab 2 - Understanding Dataset Metadata and Formats 

● Take two datasets in different formats (CSV, JSON) 

● View metadata (description, features, size, license) 

● Compare domain-specific datasets (e.g., medical vs. finance) 

  

Lab 3 - Data Annotation Exercise 

● Use MakeSense.ai or VGG Image Annotator (VIA) 

● Annotate 10 sample images (traffic signs, fruits, or medical scans) 

● Export annotations in XML or YOLO format 

● Discuss annotation errors and challenges 

  

 



Lab 4 - Data Cleaning and Visualization (Orange Data Mining) 

● Aim: To clean dirty data and visualize categorical and numeric attributes. 

● Procedure: 

1. Load dataset. 

2. Connect File → Edit Domain (to change types) and Impute (to fill missing values). 

3. Compare cleaned vs. original in Data Table. 

4. Distributions widget. 

5. Check various features distribution. 

(Optional: Create simple bar charts/line charts to visualize trends using Google Looker 

Studio) 

● Observation: Missing values filled with mean/median., Graphical representation of data. 

● Outcome: Learn importance of data cleaning., Students learn importance of visualization 

in preprocessing. 

  

Lab 5: Train/Test Split in Orange 

● Aim: To split a dataset for AI training/testing. 

● Procedure: 

1. Load Titanic dataset. 

2. Connect File → Data Sampler (70% train, 30% test). 

3. Connect outputs to Data Table widgets to view. 

● Observation: Students see two different subsets. 

● Outcome: Concept of model validation using split data. 

Lab 6: Plant Leaf Disease Detection 

● Dataset: Plant leaf disease datasets (PlantVillage, Kaggle). 

● Tool: Google Teachable Machine / Plantix app. 

● Activity: Upload leaf images to classify healthy vs diseased leaves. 

Lab 7: Crop Yield Prediction 

● Dataset: FAO crop yield datasets. 

● Tool: Orange Data Mining (drag-and-drop AI workflows). 

● Activity: Predict yield for different crops based on soil & climate features. 

 



Lab 8: Species Recognization 

● Dataset: Camera trap image datasets (Snapshot Serengeti, LILA BC). 

● Tool: iNaturalist / Wildbook AI platform. 

● Activity: Upload wildlife images for species recognition & conservation mapping. 

Lab 9: Predict and visualize 3D protein structures: 

● Dataset: Genomic & protein sequence databases (NCBI, UniProt, AlphaFold DB). 

● Tool: AlphaFold Protein Structure Viewer (online). 

● Activity: Predict and visualize 3D protein structures. 

Lab 10: Analyze chemical similarity and predict drug-likeness. 

● Dataset: Drug compound datasets (ChEMBL). 

● Tool: ChemMine Tools (web-based). 

● Activity: Analyze chemical similarity and predict drug-likeness. 

Lab 11: Identify microbial species from sequencing datasets. 

● Dataset: Metagenomics datasets (MG-RAST). 

● Tool: MG-RAST online platform. 

● Activity: Identify microbial species from sequencing datasets. 

 

Note: The Tools suggested above are tentative. Teacher/Student is free to choose any other 

similar tool to execute the said lab experiments. 

 

Books/References 

1. Data Science for Beginners, Andrew Park 

(Introductory concepts of data types, collection, cleaning, and visualization without 

coding) 

2. AI Basics for Non-Programmers, Tom Taulli 

(Clear explanations of AI data lifecycle and real-world use cases) 

3. Data Preparation for Machine Learning, Jason Brownlee 

(Conceptual understanding of dataset quality, preprocessing, and pipelines) 

4. Hands-On Data Science for Non-Programmers, David Meerman Scott 

 (Spreadsheet-based data exploration and visualization) 

5. You Look Like a Thing and I Love You – Janelle Shane 



6. Artificial Intelligence in Life Sciences – Elsevier. 

7. Artificial Intelligence in Agriculture – CRC Press (B. Prasad). 

8. AI for Ecology and Conservation – Springer. 

9. Bioinformatics and Drug Discovery using AI – Academic Press. 

10. Databases & Platforms: FAO, GBIF, PlantVillage, ChEMBL, UniProt, AlphaFold DB. 

 

Online Resources 

● Kaggle Dataset Search, https://www.kaggle.com/datasets 

● Google Dataset Search, https://datasetsearch.research.google.com 

● UCI Machine Learning Repository, https://archive.ics.uci.edu 

● Hugging Face Datasets, https://huggingface.co/datasets 

● Open Government Data (India), https://data.gov.in 

  



2. APPLICABLE TO COMMERCE AND MANAGEMENT 

SEMESTER-II 

COURSE 1: APPLICATIONS OF ARTIFICIAL INTELLIGENCE 

Theory                                             Credits: 3                                          3 hrs/week  

 

Course Objectives: 

1. Provide a foundation in the AI ecosystem, including hardware, cloud, and edge platforms 

relevant to commerce and management. 

2. Familiarize students with different types of datasets and public repositories used in AI 

research. 

3. Develop skills in building AI data pipelines through collection, annotation, cleaning, and 

preprocessing. 

4. Understand how AI enhances retail and e-commerce and explore personalization, 

recommendation systems, and customer engagement 

5. Apply AI to streamline business processes and decision-making and explore AI in finance, 

HR, and supply chain management 

Course Outcomes: 

On successful completion of this course, students will be able to: 

1. Explain the AI ecosystem (hardware, cloud, and edge devices) and its relevance to 

commerce and management. 

2. Differentiate between structured and unstructured data, and utilize public datasets for 

business-oriented AI applications. 

3. Design a conceptual AI data pipeline for solving real-world problems in commerce and 

management. 

4. Understand and apply AI technologies to improve customer engagement and 

personalization in commerce. 

5. Use AI tools to streamline business operations, enhance decision-making, and detect 

patterns in data. 

 

 



Unit 1. Infrastructure and Platforms for Building Applications using AI 

Hardware used in building AI applications: Processors - CPU, GPU, TPU, NPU, Memory - 

RAM, VRAM, Storage - HDD, SSD 

Platforms for building applications using AI: Online platforms (Example - Google AutoML, 

H2O.ai, Teachable Machine or similar platforms - for practice only); Desktop (No-code/Low-

code) platforms (Orange Data Mining, KNIME, Weka, RapidMiner or similar tools - for practice 

only). 

 

Edge AI: Concept; Applications in daily life in devices like Refrigerators, Led Bulbs, Surveillance 

Cameras, Micro Ovens, Smart Cars/Scooters; Edge AI in smart Appliances 

 

Unit 2: Foundations of Data - Types, Ethics and Utility in Building Applications using AI 

Importance of data in building AI applications: Data as the fuel for AI, Role of big data in 

training AI models. 

Conceptual Foundations of Data: Data vs. Information vs. Knowledge. 

Structure of Data: Structured, Semi-Structured, and Unstructured Data. 

Modalities of Data: Text, Image, Audio, Video, Tabular, Time-Series, and Spatial Data. 

Formats of Data: Text Formats (CSV, JSON, XML), Image Formats (JPEG, GIF, PNG), 

Audio/Video (MP3, WAV, MP4, AVI). 

Data Repositories: Definition of public Datasets; Definition of private Datasets; Importance of 

Public Datasets, Popular Public Dataset Repositories (Example - Kaggle, Hugging Face Datasets, 

UCI Machine Learning Repository, Google Dataset Search or similar ones - for demonstration 

only), Dataset licensing and usage rights. 

Ethics, Privacy in Data Usage: Privacy concerns related to data usage; Regulations governing 

data usage - GDPR, HIPAA (Overview), Ethical use of data, Responsible AI data practices. 

 

Unit 3. The AI Data Pipeline: From Collection to Model Readiness 

The AI Data Pipeline: Stages and Components: Key Stages (Data Collection, Annotation, 

Preprocessing, Splitting, Feeding into AI Models 

Core Components: Ingestion, Storage, Processing, Validation, Delivery 



Data Collection Methods for AI: Manual Input (Surveys, forms, human-curated entries), Sensors 

& IoT Devices (Real-time data from physical environments), System Logs & Transactions, Web 

Scraping (Automated extraction from websites), APIs (Structured data access from external 

platforms) 

Data Annotation and Labelling: Definition & Importance; Annotation Methods: Manual 

Annotation, Automated Annotation; Types of Annotation: Classification, Bounding Boxes, 

Segmentation, Transcription, Named Entity Recognition (NER) 

Data Cleaning and Preprocessing: Importance of data cleaning; Understanding “Dirty” Data: 

Missing Values, Duplicates, Incorrect Formats, Outliers, Noise; Steps in Data Cleaning: Identify 

Issues, Handle Errors (Imputation, Removal), Validate Cleaned Data 

Data Splitting: Splitting data into training set and test set. 

Data Transformation Techniques: Normalization, Transformation, Feature Engineering 

(Conceptual) 

 

Unit 4: AI in Commerce – Transforming the Consumer Experience 

Introduction to AI in Commerce, Recommendation Engines (Collaborative & Content-Based), 

Chatbots and Virtual Assistants, Sentiment Analysis and Review Mining, Inventory Optimization 

and Demand Forecasting, Ethical Issues related to use of AI in Commerce and Business: Bias, 

Privacy, and Transparency 

 

Unit 5: AI in Business Operations – Driving Efficiency and Insight 

AI in Business Intelligence and Predictive Analytics, Financial Applications: Fraud Detection, 

Risk Modelling, HR Applications: Resume Screening, Employee Analytics, Supply Chain 

Automation and Optimization, AI in Marketing: Customer Segmentation, Lead Scoring, Strategic 

Adoption of AI in Enterprises, Explainable AI in E-Commerce. 

 

  

 

 

 

 



2. APPLICABLE TO COMMERCE AND MANAGEMENT 

SEMESTER-II 

COURSE 1: APPLICATIONS OF ARTIFICIAL INTELLIGENCE 

Practical                                             Credits: 1                                          2 hrs/week  

 

Suggested Lab Practicals (No Coding) 

Lab 1 - Exploring Public Datasets (Orange Data Mining) 

● Visit a public repository (Kaggle, UCI, data.gov.in) 

● Download a dataset (e.g., rainfall data, literacy rates, or traffic accident statistics) 

● Procedure: 

1. Open Orange → Add File widget → Load a CSV (e.g., Titanic dataset). 

2. Connect to Data Table → View rows/columns. 

3. Connect to Data Info → Check attributes, data types. 

4. View in Data Table and Distributions widget. 

● Observation: Note numeric, categorical, missing values. 

● Outcome: Students understand structured data format in CSV. 

  

Lab 2 - Understanding Dataset Metadata and Formats 

● Take two datasets in different formats (CSV, JSON) 

● View metadata (description, features, size, license) 

● Compare domain-specific datasets (e.g., medical vs. finance) 

  

Lab 3 - Data Annotation Exercise 

● Use MakeSense.ai or VGG Image Annotator (VIA) 

● Annotate 10 sample images (traffic signs, fruits, or medical scans) 

● Export annotations in XML or YOLO format 

● Discuss annotation errors and challenges 

  

 

 



Lab 4 - Data Cleaning and Visualization (Orange Data Mining) 

● Aim: To clean dirty data and visualize categorical and numeric attributes. 

● Procedure: 

1. Load dataset. 

2. Connect File → Edit Domain (to change types) and Impute (to fill missing values). 

3. Compare cleaned vs. original in Data Table. 

4. Distributions widget. 

5. Check various features distribution. 

(Optional: Create simple bar charts/line charts to visualize trends using Google Looker 

Studio) 

● Observation: Missing values filled with mean/median., Graphical representation of data. 

● Outcome: Learn importance of data cleaning., Students learn importance of visualization 

in preprocessing. 

  

Lab 5: Train/Test Split in Orange 

● Aim: To split dataset for AI training/testing. 

● Procedure: 

1. Load Titanic dataset. 

2. Connect File → Data Sampler (70% train, 30% test). 

3. Connect outputs to Data Table widgets to view. 

● Observation: Students see two different subsets. 

● Outcome: Concept of model validation using split data. 

 

Lab 6: Introduction to AI in Commerce – Use Case Exploration 

Prerequisite: Discuss conceptually about Clustering 

Objective: Understand how AI is applied in commerce through data visualization and clustering. 

Orange Workflow: Use Orange Data Mining Tool 

Widgets Used: File → Data Table → Scatter Plot → Hierarchical Clustering 

Dataset: Retail customer data (e.g., purchase frequency, amount spent) 

Dataset Link: Retail Sales Data 

Activities: 

https://www.kaggle.com/datasets/noir1112/retail-sales-data
https://www.kaggle.com/datasets/noir1112/retail-sales-data


·                Load customer data and visualize spending patterns. 

·                Apply clustering to identify customer segments. 

·                Discuss how businesses can tailor services to each segment. 

Outcome: Students grasp how AI helps businesses understand and target consumers more 

effectively. 

  

Lab 7: Recommendation Engine Simulation 

Prerequisite: Discuss conceptually about Clustering 

Objective: Simulate collaborative filtering using similarity-based clustering. 

Orange Workflow: 

Widgets Used: File → Distance → Hierarchical Clustering → Data Table 

Dataset: User-product ratings matrix 

Dataset Link: Amazon Product Recommendation System 

Activities: 

● Calculate similarity between users. 

● Group similar users and recommend products based on cluster behavior. 

● Discuss differences between collaborative and content-based filtering. 

Outcome: Students understand the logic behind recommendation systems and how they 

personalize user experience. 

  

Lab 8: Chatbot Intent Classification 

Prerequisite: Discuss conceptually about Linear Regression & Logistic Regression 

Objective: Train a model to classify customer queries into intents. 

Orange Workflow: 

Widgets Used: File → Preprocess Text → Bag of Words → Logistic Regression → Test & 

Score 

Dataset: Sample customer queries labeled with intents (e.g., “track order”, “return item”) 

Dataset Link: Customer Intent Classification 

Activities: 

● Preprocess and vectorize text data. 

● Train a classifier to predict query intent. 

https://www.kaggle.com/code/rushiekarteekchalla/amazon-product-recommendation-system
https://www.kaggle.com/code/rushiekarteekchalla/amazon-product-recommendation-system
https://www.kaggle.com/code/youssefm0stafa/customer-intent-classifacation
https://www.kaggle.com/code/youssefm0stafa/customer-intent-classifacation


● Evaluate accuracy and discuss chatbot training. 

Outcome: Students learn how AI understands and responds to customer queries. 

  

Lab 9: Sentiment Analysis of Reviews 

Prerequisite: Discuss conceptually about Naive Bayes 

Objective: Classify customer reviews as positive or negative. 

Orange Workflow: 

Widgets Used: File → Preprocess Text → Bag of Words → Naive Bayes → Test & Score 

Dataset: Product reviews with sentiment labels 

Dataset Link: Amazon Product Reviews – Sentiment Analysis 

Activities: 

● Clean and tokenize review text. 

● Train a sentiment classifier. 

● Visualize word clouds for positive vs. negative reviews. 

Outcome: Students analyze customer feedback and extract actionable insights. 

 

Lab 10: Demand Forecasting with Regression 

Prerequisite: Discuss conceptually about Linear Regression & Logistic Regression 

Objective: Predict future sales using regression models. 

Orange Workflow: 

Widgets Used: File → Linear Regression → Scatter Plot → Test & Score   

Dataset: Historical sales data (e.g., monthly sales, promotions) 

Dataset Link: Comprehensive Retail Sales Data 

Activities: 

● Train a regression model to forecast sales. 

● Visualize predictions vs. actuals. 

● Discuss implications for inventory planning. 

Outcome: Students understand how AI supports demand forecasting and inventory control. 

  

 

 

https://www.kaggle.com/datasets/miriamodeyianypeter/sentiment-analysis-amazon-product-reviews
https://www.kaggle.com/datasets/miriamodeyianypeter/sentiment-analysis-amazon-product-reviews
https://www.kaggle.com/datasets/shelendata/comprehensive-dataset-for-retail-data-analysis
https://www.kaggle.com/datasets/shelendata/comprehensive-dataset-for-retail-data-analysis


Lab 11: Bias Detection in AI Models 

Prerequisite: Discuss conceptually about Linear Regression, Logistic Regression & Confusion 

Matrix 

Objective: Explore bias in predictive models and its impact. 

Orange Workflow: 

Widgets Used: File → Logistic Regression → Confusion Matrix → Distributions  

Dataset: HR hiring data with gender or age attributes 

Dataset Link: HR Data Analytics 

Activities: 

● Train a model to predict hiring decisions. 

● Analyze performance across demographic groups. 

● Discuss fairness, transparency, and ethical implications. 

Outcome: Students critically assess bias and propose ethical safeguards. 

  

Lab 12: Predictive Analytics for Business Intelligence 

Prerequisite: Discuss conceptually about Random Forest 

Objective: Use classification to predict customer churn. 

Orange Workflow: 

Widgets Used: File → Random Forest → Test & Score → ROC Analysis 

Dataset: Telecom or subscription data with churn labels 

Dataset Link: Telco Customer Churn – IBM Dataset 

Activities: 

● Train and evaluate a churn prediction model. 

● Interpret ROC curves and accuracy. 

● Discuss how businesses can act on predictions. 

Outcome: Students apply predictive analytics to improve customer retention. 

  

Lab 13: AI in HR and Marketing – Resume Screening & Segmentation 

Prerequisite: Discuss conceptually about Clustering 

Objective: Classify resumes and segment customers using clustering. 

Orange Workflow: 

https://www.kaggle.com/datasets/samruddhi4040/hr-data-analytics
https://www.kaggle.com/datasets/samruddhi4040/hr-data-analytics
https://www.kaggle.com/datasets/yeanzc/telco-customer-churn-ibm-dataset
https://www.kaggle.com/datasets/yeanzc/telco-customer-churn-ibm-dataset


HR Task: File → Preprocess Text → Bag of Words → Logistic Regression 

Marketing Task: File → k-Means Clustering → Scatter Plot  

Resume Screening Dataset: Employee Hiring Data 

Customer Segmentation Dataset: Customer Segmentation Dataset 

Activities: 

● Screen resumes based on job fit. 

● Segment customers by behavior or demographics. 

● Discuss automation benefits and risks. 

Outcome: Students explore how AI enhances HR and marketing efficiency. 

 

Note: The Tools suggested above are tentative. Teacher/Student is free to choose any other 

similar tool to execute the said lab experiments. 

 

Books/References 

1. Data Science for Beginners, Andrew Park 

(Introductory concepts of data types, collection, cleaning, and visualization without 

coding) 

2. AI Basics for Non-Programmers, Tom Taulli 

(Clear explanations of AI data lifecycle and real-world use cases) 

3. Data Preparation for Machine Learning, Jason Brownlee 

(Conceptual understanding of dataset quality, preprocessing, and pipelines) 

4. Hands-On Data Science for Non-Programmers, David Meerman Scott 

 (Spreadsheet-based data exploration and visualization) 

5. You Look Like a Thing and I Love You – Janelle Shane 

 

 

 

 

 

 

 

 

 

 

 

 

https://www.kaggle.com/datasets/malsha/employee-hiring-data
https://www.kaggle.com/datasets/malsha/employee-hiring-data
https://www.kaggle.com/datasets/teddybrown414/customer-segmentation-dataset-from-a-company
https://www.kaggle.com/datasets/teddybrown414/customer-segmentation-dataset-from-a-company


3. APPLICABLE TO HISTORY, ECONOMICS, POLITICAL SCIENCE, 

LINGUISTICS, AND ANY OTHER HUMANITIES 

SEMESTER-II 

COURSE 1: APPLICATIONS OF ARTIFICIAL INTELLIGENCE 

Theory                                             Credits: 3                                          3 hrs/week  

Course Objectives 

1. Provide a foundation in the AI ecosystem, including hardware, cloud, and edge platforms, 

in a non-technical way for Arts and Social Sciences students. 

2. Familiarize students with data types, sources, and public repositories that fuel AI 

applications in society and humanities. 

3. Explain the process of preparing and managing AI data pipelines through collection, 

annotation, and cleaning. 

4. Explore real-world applications of AI in arts, culture, literature, linguistics, and languages. 

5. Introduce applications of AI in social sciences such as economics, political science, 

psychology, history, and sociology, with an emphasis on ethics and responsible adoption. 

 

Course Outcomes 

On successful completion of this course, students will be able to: 

1. Explain the AI ecosystem (hardware, cloud, edge devices) and its societal relevance. 

2. Differentiate data types and identify public datasets relevant to social sciences, arts, and 

humanities. 

3. Describe the steps of an AI data pipeline (collection, annotation, cleaning, preparation) in 

simple terms. 

4. Illustrate the role of AI in arts, languages, and cultural heritage with practical, real-world 

examples. 

5. Analyze applications of AI in social sciences (economics, politics, psychology, history, 

and society) and evaluate ethical concerns. 

 

 

 



Unit 1. Infrastructure and Platforms for Building Applications using AI 

Hardware used in building AI applications: Processors - CPU, GPU, TPU, NPU, Memory - 

RAM, VRAM, Storage - HDD, SSD 

Platforms for building applications using AI: Online platforms (Example - Google AutoML, 

H2O.ai, Teachable Machine or similar platforms - for practice only); Desktop (No-code/Low-

code) platforms (Orange Data Mining, KNIME, Weka, RapidMiner or similar tools - for practice 

only). 

 

Edge AI: Concept; Applications in daily life in devices like Refrigerators, Led Bulbs, Surveillance 

Cameras, Micro Ovens, Smart Cars/Scooters; Edge AI in smart Appliances 

 

Unit 2: Foundations of Data - Types, Ethics and Utility in Building Applications using AI 

Importance of data in building AI applications: Data as the fuel for AI, Role of big data in 

training AI models. 

Conceptual Foundations of Data: Data vs. Information vs. Knowledge. 

Structure of Data: Structured, Semi-Structured, and Unstructured Data. 

Modalities of Data: Text, Image, Audio, Video, Tabular, Time-Series, and Spatial Data. 

Formats of Data: Text Formats (CSV, JSON, XML), Image Formats (JPEG, GIF, PNG), 

Audio/Video (MP3, WAV, MP4, AVI). 

Data Repositories: Definition of public Datasets; Definition of private Datasets; Importance of 

Public Datasets, Popular Public Dataset Repositories (Example - Kaggle, Hugging Face Datasets, 

UCI Machine Learning Repository, Google Dataset Search or similar ones - for demonstration 

only), Dataset licensing and usage rights. 

Ethics, Privacy in Data Usage: Privacy concerns related to data usage; Regulations governing 

data usage - GDPR, HIPAA (Overview), Ethical use of data, Responsible AI data practices. 

 

Unit 3. The AI Data Pipeline: From Collection to Model Readiness 

The AI Data Pipeline: Stages and Components: Key Stages (Data Collection, Annotation, 

Preprocessing, Splitting, Feeding into AI Models 

Core Components: Ingestion, Storage, Processing, Validation, Delivery 



Data Collection Methods for AI: Manual Input (Surveys, forms, human-curated entries), Sensors 

& IoT Devices (Real-time data from physical environments), System Logs & Transactions, Web 

Scraping (Automated extraction from websites), APIs (Structured data access from external 

platforms) 

Data Annotation and Labelling: Definition & Importance; Annotation Methods: Manual 

Annotation, Automated Annotation; Types of Annotation: Classification, Bounding Boxes, 

Segmentation, Transcription, Named Entity Recognition (NER) 

Data Cleaning and Preprocessing: Importance of data cleaning; Understanding “Dirty” Data: 

Missing Values, Duplicates, Incorrect Formats, Outliers, Noise; Steps in Data Cleaning: Identify 

Issues, Handle Errors (Imputation, Removal), Validate Cleaned Data 

Data Splitting: Splitting data into training set and test set. 

Data Transformation Techniques: Normalization, Transformation, Feature Engineering 

(Conceptual) 

Unit 4: AI in Social Sciences and Society: 

AI in Economics: Predicting market trends, consumer behavior, and economic forecasting. 

AI in Political Science & Public Policy: Social media analysis for political campaigns, Opinion 

mining & election trend prediction. 

AI in Psychology & Sociology: Emotion recognition from facial expressions and text, AI chatbots 

in mental health counseling (conceptual).  

AI in History & Society: Digital archives and historical document analysis,AI for preserving 

ancient languages and scripts, Social impact of AI on jobs, privacy, and democracy.  

  

Unit 5: AI in Arts, Languages, and Cultural Studies 

AI in Literature & Languages: Machine translation (Google Translate, DeepL), Sentiment 

analysis in literature and media reviews, AI-assisted creative writing (chatbots, story generators, 

poetry) 

AI in Arts & Culture: AI in music composition & art generation (painting, film scripts), 

Digitization and preservation of cultural heritage using AI, Identifying fake art and forgeries 

 

 

 



3. APPLICABLE TO HISTORY, ECONOMICS, POLITICAL SCIENCE, 

LINGUISTICS, AND ANY OTHER HUMANITIES 

SEMESTER-II 

COURSE 1: APPLICATIONS OF ARTIFICIAL INTELLIGENCE 

Practical                                             Credits: 1                                          2 hrs/week  

 

Lab Experiments: 

Lab 1: Explore Open Data (Economics / Sociology) 

● Tool: Our World in Data or World Bank Data Explorer 

(https://data360.worldbank.org/en/search) 

● Task: Choose indicators (e.g., Literacy, GDP per capita, Poverty, Unemployment). 

● Procedure: 

1. Open World Bank / Our World in Data. 

2. Select one country or compare multiple countries. 

3. Use the interactive charts to see historical trends. 

● Observation: How does education level impact income or health? 

● Outcome: Understand correlations between socio-economic indicators. 

 

Lab 2: Data Annotation (NER & Classification) 

● Tool: Prodigy Demo (https://demo.prodi.gy/) -free online demo, no install 

● Activity: 

1. Try Named Entity Recognition (NER) demo. 

2. Highlight organizations, people, and places in sample text. 

3. Compare manual vs. automated annotation. 

● Outcome: Students understand manual vs. automated annotation and why labeling is 

crucial. 

Lab 3: Automatic Text Classification for Sociology 

● Tool: Text2Data Sentiment Analysis Demo (https://text2data.com/Demo) -free online 

demo 

● Task: Copy-paste 5 messages related to climate change, caste or gender. 

https://data360.worldbank.org/en/search
https://demo.prodi.gy/
https://text2data.com/Demo


● Observation: Tool classifies them as Positive, Neutral, or Negative. 

● Outcome: Understand “annotation” and “classification labels.” 

 

Lab 4: Word Clouds for Political Speeches (Languages / Political Science) 

● Tool: WordArt Cloud Generator (https://wordart.com/create) - Free Online 

● Procedure: 

1. Copy a Prime Minister’s speech or Economic Budget highlights. 

2. Paste into WordArt. 

3. Generate a word cloud → biggest words = most repeated. 

● Observation: Main themes in political communication. 

● Outcome: Learn how text visualization shows political/economic priorities. 

 

Lab 5: Bias in Job Advertisements (Sociology / Gender Studies) 

● Tool: Gender Decoder for Job Ads (https://gender-decoder.katmatfield.com/) -Free Online 

or Any other related tool 

● Procedure: 

1. Copy text from 5 job advertisements. 

2. Paste into the gender bias detector. 

3. Note masculine vs feminine coded words. 

● Observation: How language influences gendered hiring. 

● Outcome: Awareness of AI in analyzing workplace bias. 

Lab 6: Language Detection & Translation (Languages / Linguistics) 

● Tool: Google Translate (https://translate.google.co.in/)  

● Task: Enter text in regional/foreign languages. 

● Procedure: 

1. Paste short paragraph in Telugu, Hindi, French, etc. 

2. Translate into English. 

3. Reverse-translate to see changes. 

● Observation: Which meanings are lost in translation? 

● Outcome: Students understand AI’s strengths/limits in translation. 

 

https://wordart.com/create
https://gender-decoder.katmatfield.com/
https://translate.google.co.in/


Lab 7: Text Summarization of Articles (Languages / Literature) 

● Tool: SMMRY (https://smmry.com/) or  

Scholarcy Free Summarizer (https://www.scholarcy.com/article-summarizer) 

● Task: Take a long article or essay. 

● Procedure: 

1. Paste article into tool. 

2. Generate summary. 

3. Compare AI summary vs. student’s manual summary. 

● Observation: AI captures main ideas but may miss nuances. 

● Outcome: Learn how AI helps in academic reading & summarization. 

 

Lab 8: Talk to a Free Chatbot 

● Tool: ChatGPT Free or Poe or any other related tool 

● Activity: Students ask questions like: 

○ “Tell me a Telugu proverb and its meaning.” 

○ “Explain World War II in 5 simple lines.” 

● Outcome: Data delivery/output stage - AI as a dialogue system. 

 

Lab 9:  Story Generator (Creative Writing / Literature) 

● Tool: AI Dungeon (https://play.aidungeon.com/) -free play or DeepAI Text Generator 

(https://deepai.org/chat/text-generator)  

● Activity: Give a starting line (e.g., “Once upon a time in Amaravati…”) → AI continues 

story 

● Outcome: How training data influences creativity in AI. 

Lab 10: AI Art Generator (Culture & Arts) 

● Tool: DeepAI Text-to-Image (free) (https://deepai.org/machine-learning-

model/text2img) or any other related tool 

● Activity: Ask students to generate: 

○ “A painting of Bharat Mata in Picasso style.” 

○ “Hyderabad Charminar in futuristic design.” 

● Outcome: Data pipeline applied to images. 

https://smmry.com/
https://chat.openai.com/
https://chat.openai.com/
https://play.aidungeon.com/
https://deepai.org/chat/text-generator
https://deepai.org/machine-learning-model/text2img
https://deepai.org/machine-learning-model/text2img


 

Lab 11: AI Music Generation with Soundraw (Free Trial) 

Tool: Soundraw.io 

Steps: 

Open the website → Click Create Music. 

Select Mood (happy, sad, chill, dramatic). 

Select Genre (pop, jazz, cinematic, lo-fi, etc.). 

The AI will generate a full instrumental track. 

You can adjust instruments, tempo, and structure. 

Outcome: Students understand how AI composes music automatically based on mood/genre → 

linking to psychology, culture, and media studies. 

Lab 12:  Chatbot Roleplay (History / Social Science) 

● Tool: Character.AI (free, no coding)- https://character.ai/ 

● Activity: Talk to AI characters like “Einstein” or “Shakespeare” and ask them questions. 

You can try with other AI characters and experiment.  

● Learning: How AI mimics personalities using training data. 

 

Note: The Tools suggested above are tentative. Teacher/Student is free to choose any other 

similar tool to execute the said lab experiments. 

 

Books/References 

1. Data Science for Beginners, Andrew Park 

(Introductory concepts of data types, collection, cleaning, and visualization without 

coding) 

2. AI Basics for Non-Programmers, Tom Taulli 

(Clear explanations of AI data lifecycle and real-world use cases) 

3. Data Preparation for Machine Learning, Jason Brownlee 

(Conceptual understanding of dataset quality, preprocessing, and pipelines) 

4. Hands-On Data Science for Non-Programmers, David Meerman Scott 

 (Spreadsheet-based data exploration and visualization) 

5. You Look Like a Thing and I Love You – Janelle Shane 

https://character.ai/


4. APPLICABLE TO MATHEMATICS, PHYSICS, CHEMISTRY AND ANY OTHER 

MATHEMATICAL SCIENCES 

SEMESTER-II 

COURSE 1: APPLICATIONS OF ARTIFICIAL INTELLIGENCE 

Theory                                             Credits: 3                                          3 hrs/week  

 

Course Objectives 

1. Provide a foundational understanding of AI platforms, data pipelines, and their importance 

in the physical sciences. 

2. Introduce real-world datasets and public repositories relevant to physics, chemistry, 

mathematics, and earth sciences. 

3. Explain how AI is applied to solve scientific problems, discover patterns, and support 

research in physical sciences in a simple, non-coding manner. 

4. Highlight ethical concerns, data challenges, and the future of AI-driven discoveries in 

physical sciences. 

 

Course Outcomes 

On successful completion of this course, students will be able to: 

1. Explain the AI ecosystem (hardware, cloud, and edge devices) in relation to physical 

sciences applications. 

2. Identify scientific data types and public repositories relevant to physics, chemistry, 

mathematics, and earth sciences. 

3. Describe the process of preparing and managing scientific data pipelines. 

4. Illustrate the role of AI in solving real-world scientific challenges in physics, chemistry, 

mathematics, and earth sciences. 

5. Analyze ethical, environmental, and societal impacts of AI-driven scientific applications. 

 

Unit 1. Infrastructure and Platforms for Building Applications using AI 

Hardware used in building AI applications: Processors - CPU, GPU, TPU, NPU, Memory - 

RAM, VRAM, Storage - HDD, SSD 



Platforms for building applications using AI: Online platforms (Example - Google AutoML, 

H2O.ai, Teachable Machine or similar platforms - for practice only); Desktop (No-code/Low-

code) platforms (Orange Data Mining, KNIME, Weka, RapidMiner or similar tools - for practice 

only). 

Edge AI: Concept; Applications in daily life in devices like Refrigerators, Led Bulbs, Surveillance 

Cameras, Micro Ovens, Smart Cars/Scooters; Edge AI in smart Appliances 

 

Unit 2: Foundations of Data - Types, Ethics and Utility in Building Applications using AI 

Importance of data in building AI applications: Data as the fuel for AI, Role of big data in 

training AI models. 

Conceptual Foundations of Data: Data vs. Information vs. Knowledge. 

Structure of Data: Structured, Semi-Structured, and Unstructured Data. 

Modalities of Data: Text, Image, Audio, Video, Tabular, Time-Series, and Spatial Data. 

Formats of Data: Text Formats (CSV, JSON, XML), Image Formats (JPEG, GIF, PNG), 

Audio/Video (MP3, WAV, MP4, AVI). 

Data Repositories: Definition of public Datasets; Definition of private Datasets; Importance of 

Public Datasets, Popular Public Dataset Repositories (Example - Kaggle, Hugging Face Datasets, 

UCI Machine Learning Repository, Google Dataset Search or similar ones - for demonstration 

only), Dataset licensing and usage rights. 

Ethics, Privacy in Data Usage: Privacy concerns related to data usage; Regulations governing 

data usage - GDPR, HIPAA (Overview), Ethical use of data, Responsible AI data practices. 

 

Unit 3. The AI Data Pipeline: From Collection to Model Readiness 

The AI Data Pipeline: Stages and Components: Key Stages (Data Collection, Annotation, 

Preprocessing, Splitting, Feeding into AI Models 

Core Components: Ingestion, Storage, Processing, Validation, Delivery 

Data Collection Methods for AI: Manual Input (Surveys, forms, human-curated entries), Sensors 

& IoT Devices (Real-time data from physical environments), System Logs & Transactions, Web 

Scraping (Automated extraction from websites), APIs (Structured data access from external 

platforms) 



Data Annotation and Labelling: Definition & Importance; Annotation Methods: Manual 

Annotation, Automated Annotation; Types of Annotation: Classification, Bounding Boxes, 

Segmentation, Transcription, Named Entity Recognition (NER) 

Data Cleaning and Preprocessing: Importance of data cleaning; Understanding “Dirty” Data: 

Missing Values, Duplicates, Incorrect Formats, Outliers, Noise; Steps in Data Cleaning: Identify 

Issues, Handle Errors (Imputation, Removal), Validate Cleaned Data 

Data Splitting: Splitting data into training set and test set. 

Data Transformation Techniques: Normalization, Transformation, Feature Engineering 

(Conceptual) 

Unit 4: AI in Physical Sciences (Physics & Chemistry Applications) 

AI in Physics: AI for analyzing astronomical images (identifying galaxies, stars, exoplanets), 

CERN Datasets for Particle Physics. 

AI in material science: discovering new superconductors and quantum materials 

AI in energy: predicting power grid loads, optimizing solar and wind energy systems 

AI in Chemistry: 

Protein structure prediction (AlphaFold). 

AI in drug discovery - virtual screening of compounds. 

AI in chemistry - reaction outcome & material property prediction. 

Unit 5: AI in Mathematics and Earth Sciences 

AI in Mathematics: 

Pattern recognition in large datasets (fractals, chaos systems, number theory) 

Automated theorem proving and symbolic mathematics 

AI in optimization problems (transport, logistics, resource allocation) 

(Explore the Wolfram Alpha Tool: https://www.wolframalpha.com/examples/mathematics)  

AI in Earth Sciences 

Climate modeling: AI predicting weather patterns, cyclones, and long-term climate change 

Remote sensing: AI analyzing satellite images for deforestation, urbanization, and natural resource 

mapping 

Earthquake and natural disaster prediction using sensor networks 

AI in geology: identifying mineral deposits, oil, and groundwater reserves 

 

https://www.wolframalpha.com/examples/mathematics


APPLICABLE TO MATHEMATICS, PHYSICS, CHEMISTRY AND ANY OTHER 

MATHEMATICAL SCIENCES 

SEMESTER-II 

COURSE 1: APPLICATIONS OF ARTIFICIAL INTELLIGENCE 

Practicxal                                             Credits: 1                                          2 hrs/week  

 

Suggested Lab Practicals (No Coding) 

Lab 1 - Exploring Public Datasets (Orange Data Mining) 

● Visit a public repository (Kaggle, UCI, data.gov.in) 

● Download a dataset (e.g., rainfall data, literacy rates, or traffic accident statistics) 

● Procedure: 

1. Open Orange → Add File widget → Load a CSV (e.g., Titanic dataset). 

2. Connect to Data Table → View rows/columns. 

3. Connect to Data Info → Check attributes, data types. 

4. View in Data Table and Distributions widget. 

● Observation: Note numeric, categorical, missing values. 

● Outcome: Students understand structured data format in CSV. 

 

Lab 2 -  Exploring Scientific Datasets  

Dataset: Earth datasets, Physics Particle Dataset 

Tool: Orange Data Mining. 

Activity: 

● Load a CSV (e.g., earthquake dataset:  

https://www.kaggle.com/datasets/warcoder/earthquake-dataset 

Physics particle dataset: 

https://www.kaggle.com/datasets/dsfelix/physics-particles ) 

● Use Data Table + Distributions to view features. 

● Compare categorical vs numerical attributes. 

Outcome: Students understand how scientific datasets are structured and visualized. 

 

https://www.kaggle.com/datasets/warcoder/earthquake-dataset
https://www.kaggle.com/datasets/dsfelix/physics-particles


 

Lab 3 - Understanding Dataset Metadata and Formats 

● Take two datasets in different formats (CSV, JSON) 

● View metadata (description, features, size, license) 

● Compare domain-specific datasets (e.g., medical vs. finance) 

  

Lab 4 - Data Annotation Exercise 

● Use MakeSense.ai or VGG Image Annotator (VIA) 

● Annotate 10 sample images (traffic signs, fruits, or medical scans) 

● Export annotations in XML or YOLO format 

● Discuss annotation errors and challenges 

  

Lab 5 - Data Cleaning and Visualization (Orange Data Mining) 

● Aim: To clean dirty data and visualize categorical and numeric attributes. 

● Procedure: 

1. Load dataset. 

2. Connect File → Edit Domain (to change types) and Impute (to fill missing values). 

3. Compare cleaned vs. original in Data Table. 

4. Distributions widget. 

5. Check various features distribution. 

(Optional: Create simple bar charts/line charts to visualize trends using Google Looker 

Studio) 

● Observation: Missing values filled with mean/median., Graphical representation of data. 

● Outcome: Learn importance of data cleaning., Students learn importance of visualization 

in preprocessing. 

  

Lab 6: Train/Test Split in Orange 

● Aim: To split dataset for AI training/testing. 

● Procedure: 

1. Load Titanic dataset. 

2. Connect File → Data Sampler (70% train, 30% test). 



3. Connect outputs to Data Table widgets to view. 

● Observation: Students see two different subsets. 

● Outcome: Concept of model validation using split data. 

 

Lab 7 – Material Science Data Exploration (Chemistry + Physics) 

Dataset: Materials Project Database (https://next-gen.materialsproject.org/ ) OR Kaggle 

chemistry datasets (https://www.kaggle.com/competitions?tagIds=7402-Chemistry) . 

Tool: Orange Data Mining. 

Activity: 

Load material/compound dataset (e.g., band gap, conductivity). 

Visualize trends (scatter plots, bar charts). 

Identify correlations between features. 

Outcome: Students see how AI identifies new material properties. 

 

Lab 8 – Earthquake Prediction Data Analysis (Earth Sciences) 

Dataset: USGS Earthquake Dataset (public): 

https://www.kaggle.com/datasets/rupindersinghrana/usgs-earthquakes-2024 

Tool: Orange Data Mining 

Activity: 

● Load earthquake data (time, magnitude, depth). 

● Plot frequency over time & regions. 

● Perform simple clustering (e.g., k-means in Orange). 

Outcome: Understand how AI detects seismic patterns. 

 

Lab 9– Climate Data Visualization (Earth Sciences) 

Dataset: NASA GISS climate dataset (https://data.giss.nasa.gov/gistemp/)  / FAO rainfall data 

(https://www.fao.org/aquastat/en/geospatial-information/climate-information) . 

Tool: Google Looker Studio (free dashboard tool). 

Activity: 

● Import CSV of temperature/rainfall data. 

● Build trend graphs and heat maps. 

https://next-gen.materialsproject.org/
https://www.kaggle.com/competitions?tagIds=7402-Chemistry
https://www.kaggle.com/datasets/rupindersinghrana/usgs-earthquakes-2024
https://data.giss.nasa.gov/gistemp/
https://www.fao.org/aquastat/en/geospatial-information/climate-information


Outcome: Learn visualization of climate patterns & anomalies. 

 

Lab 10 – Chemical Compound Classification (Chemistry) 

Prerequisite: Discuss conceptually about Clustering 

Dataset: PubChem / ChEMBL chemical datasets. 

(https://pubchem.ncbi.nlm.nih.gov/source/ChEMBL)  

Tool: ChemMine Tools (free web-based). (https://chemminetools.ucr.edu/) 

Activity: 

● Input chemical structures or SMILES notations. 

● Predict chemical similarity clusters. 

● Analyze “drug-likeness” properties. 

Outcome: Understanding AI in drug discovery & reaction prediction. 

 

Lab 11 – Symbolic Mathematics Solver (Mathematics) 

Dataset: Wolfram Alpha examples / OpenMath datasets. 

Tool: MathPix (OCR) + Symbolab / WolframAlpha (free tier)- https://www.wolframalpha.com/ 

Activity: 

● Input handwritten/scanned math problems using MathPix. 

● Use Wolfram Alpha to see symbolic solving. 

● Compare AI vs manual solution steps. 

Outcome: Understand automated theorem proving and symbolic AI. 

 

Lab 11 – Explore the Mathematical AI tool 

Tool: WolframAlpha (free tier)- https://www.wolframalpha.com/ 

Activity: 

● Solve specific math problems or find information on Mathematical subjects and topics. 

Outcome: Understand deep computational power of AI tools in solving Math Problems. 

 

Lab 12 – Explore various Remote Sensing Datasets 

Tool: https://developers.google.com/earth-engine/datasets/ 

Activity: 

https://pubchem.ncbi.nlm.nih.gov/source/ChEMBL
https://chemminetools.ucr.edu/
https://www.wolframalpha.com/
https://www.wolframalpha.com/
https://developers.google.com/earth-engine/datasets/


● Explore any Three Satellite Sensor Datasets 

● Identify the Significance and the Period of Availability 

● Study various bands available in the data 

Outcome: Understand various Remote Sensing Datasets. 

 

Note: The Tools suggested above are tentative. Teacher/Student is free to choose any other 

similar tool to execute the said lab experiments. 

 

Books/References 

1. Data Science for Beginners, Andrew Park 

(Introductory concepts of data types, collection, cleaning, and visualization without 

coding) 

2. AI Basics for Non-Programmers, Tom Taulli 

(Clear explanations of AI data lifecycle and real-world use cases) 

3. Data Preparation for Machine Learning, Jason Brownlee 

(Conceptual understanding of dataset quality, preprocessing, and pipelines) 

4. Hands-On Data Science for Non-Programmers, David Meerman Scott 

 (Spreadsheet-based data exploration and visualization) 

5. You Look Like a Thing and I Love You – Janelle Shane 

6. AI in Astronomy: 

https://www.borntoengineer.com/how-is-artificial-intelligence-is-helping-us-learn-about-

the-universe 

https://primo.ai/index.php/Astronomy 

7. CERN datasets for Particle Physics: https://opendata.cern.ch/ 

8. AI in Material Science:  

https://deepmind.google/discover/blog/millions-of-new-materials-discovered-with-deep-

learning/ 

https://www.temasek.com.sg/content/dam/temasek-corporate/news-and-

views/resources/reports/ai-meets-materials.pdf 

9. AI in Energy: https://www.xenonstack.com/blog/ai-renewable-energy-production 

https://www.borntoengineer.com/how-is-artificial-intelligence-is-helping-us-learn-about-the-universe
https://www.borntoengineer.com/how-is-artificial-intelligence-is-helping-us-learn-about-the-universe
https://primo.ai/index.php/Astronomy
https://opendata.cern.ch/
https://deepmind.google/discover/blog/millions-of-new-materials-discovered-with-deep-learning/
https://deepmind.google/discover/blog/millions-of-new-materials-discovered-with-deep-learning/
https://www.temasek.com.sg/content/dam/temasek-corporate/news-and-views/resources/reports/ai-meets-materials.pdf
https://www.temasek.com.sg/content/dam/temasek-corporate/news-and-views/resources/reports/ai-meets-materials.pdf
https://www.xenonstack.com/blog/ai-renewable-energy-production


https://www.sandtech.com/insight/how-ai-is-transforming-the-future-in-energy-

management/ 

10. AI in Chemistry:  

https://chemintelligence.com/ai-for-chemistry 

https://deepmind.google/science/alphafold/ 

https://aimagazine.com/articles/alphafold-2-the-ai-system-that-won-google-a-nobel-prize 

https://blog.google/technology/ai/google-deepmind-isomorphic-alphafold-3-ai-

model/#life-molecules 

11. AI in Drug Discovery:  

https://www.ddw-online.com/the-promise-of-ai-advancing-drug-discovery-with-ultra-

large-library-processing-29063-202403/ 

https://www.medchemexpress.com/ai-driven-drug-

screening.html?srsltid=AfmBOoqhDeVNqW9S5vn1m4FZargNAKEFdOKaPvwsnOIzen

QEEJoWkz8J 

12. AI in Optimization Problems: 

https://throughput.world/blog/ai-in-transportation-and-logistics/ 

https://codewave.com/insights/ai-transforming-transportation-logistics/ 

13. AI in Remote Sensing: 

https://www.satimagingcorp.com/applications/artificial-intelligence-ai/ 

  

https://www.sandtech.com/insight/how-ai-is-transforming-the-future-in-energy-management/
https://www.sandtech.com/insight/how-ai-is-transforming-the-future-in-energy-management/
https://chemintelligence.com/ai-for-chemistry
https://deepmind.google/science/alphafold/
https://aimagazine.com/articles/alphafold-2-the-ai-system-that-won-google-a-nobel-prize
https://blog.google/technology/ai/google-deepmind-isomorphic-alphafold-3-ai-model/#life-molecules
https://blog.google/technology/ai/google-deepmind-isomorphic-alphafold-3-ai-model/#life-molecules
https://www.ddw-online.com/the-promise-of-ai-advancing-drug-discovery-with-ultra-large-library-processing-29063-202403/
https://www.ddw-online.com/the-promise-of-ai-advancing-drug-discovery-with-ultra-large-library-processing-29063-202403/
https://www.medchemexpress.com/ai-driven-drug-screening.html?srsltid=AfmBOoqhDeVNqW9S5vn1m4FZargNAKEFdOKaPvwsnOIzenQEEJoWkz8J
https://www.medchemexpress.com/ai-driven-drug-screening.html?srsltid=AfmBOoqhDeVNqW9S5vn1m4FZargNAKEFdOKaPvwsnOIzenQEEJoWkz8J
https://www.medchemexpress.com/ai-driven-drug-screening.html?srsltid=AfmBOoqhDeVNqW9S5vn1m4FZargNAKEFdOKaPvwsnOIzenQEEJoWkz8J
https://throughput.world/blog/ai-in-transportation-and-logistics/
https://codewave.com/insights/ai-transforming-transportation-logistics/
https://www.satimagingcorp.com/applications/artificial-intelligence-ai/


5. APPLICABLE TO COMPUTER SCIENCE, DATA SCIENCE, ARTIFICIAL 

INTELLIGENCE, COGNITIVE SYSTEMS, DATA ANALYTICS, CLOUD 

COMPUTING, CYBER SECURITY AND ANY OTHER COMPUTER SCIENCE 

ALLIED STREAMS 

SEMESTER-II 

COURSE 1: APPLICATIONS OF ARTIFICIAL INTELLIGENCE 

Theory                                             Credits: 3                                          3 hrs/week  

 

Course Objectives 

1. Provide a foundation in the AI ecosystem, including hardware, cloud, and edge platforms 

relevant to Computer science. 

2. Familiarize students with different types of datasets and public repositories used in AI 

research. 

3. Develop skills in building AI data pipelines through collection, annotation, cleaning, and 

preprocessing. 

4. Expose students to no-code AI platforms, vibe coding, and workflow automation tools for 

rapid AI application development. 

5. Introduce applications of AI in networking, cybersecurity, and digital forensics, 

highlighting both opportunities and challenges. 

 

Course Outcomes 

On successful completion of this course, students will be able to: 

1. Explain the role of AI hardware, edge devices, and cloud platforms in enabling applications 

in Computer Science. 

2. Differentiate data types and utilize public datasets relevant to AI. 

3. Design and implement a conceptual AI data pipeline for solving problems. 

4. Apply no-code/low-code AI platforms, vibe coding tools, and workflow automation for 

simple AI-powered applications. 



5. Evaluate the role of AI in networking, cybersecurity, and digital forensics, and discuss its 

challenges and future scope. 

 

Unit 1. Infrastructure and Platforms for Building Applications using AI 

Hardware used in building AI applications: Processors - CPU, GPU, TPU, NPU, Memory - 

RAM, VRAM, Storage - HDD, SSD 

Platforms for building applications using AI: Online platforms (Example - Google AutoML, 

H2O.ai, Teachable Machine or similar platforms - for practice only); Desktop (No-code/Low-

code) platforms (Orange Data Mining, KNIME, Weka, RapidMiner or similar tools - for practice 

only). 

 

Edge AI: Concept; Applications in daily life in devices like Refrigerators, Led Bulbs, Surveillance 

Cameras, Micro Ovens, Smart Cars/Scooters; Edge AI in smart Appliances 

 

Unit 2: Foundations of Data - Types, Ethics and Utility in Building Applications using AI 

Importance of data in building AI applications: Data as the fuel for AI, Role of big data in 

training AI models. 

Conceptual Foundations of Data: Data vs. Information vs. Knowledge. 

Structure of Data: Structured, Semi-Structured, and Unstructured Data. 

Modalities of Data: Text, Image, Audio, Video, Tabular, Time-Series, and Spatial Data. 

Formats of Data: Text Formats (CSV, JSON, XML), Image Formats (JPEG, GIF, PNG), 

Audio/Video (MP3, WAV, MP4, AVI). 

Data Repositories: Definition of public Datasets; Definition of private Datasets; Importance of 

Public Datasets, Popular Public Dataset Repositories (Example - Kaggle, Hugging Face Datasets, 

UCI Machine Learning Repository, Google Dataset Search or similar ones - for demonstration 

only), Dataset licensing and usage rights. 

Ethics, Privacy in Data Usage: Privacy concerns related to data usage; Regulations governing 

data usage - GDPR, HIPAA (Overview), Ethical use of data, Responsible AI data practices. 

 

 

 



Unit 3. The AI Data Pipeline: From Collection to Model Readiness 

The AI Data Pipeline: Stages and Components: Key Stages (Data Collection, Annotation, 

Preprocessing, Splitting, Feeding into AI Models 

Core Components: Ingestion, Storage, Processing, Validation, Delivery 

Data Collection Methods for AI: Manual Input (Surveys, forms, human-curated entries), Sensors 

& IoT Devices (Real-time data from physical environments), System Logs & Transactions, Web 

Scraping (Automated extraction from websites), APIs (Structured data access from external 

platforms) 

Data Annotation and Labelling: Definition & Importance; Annotation Methods: Manual 

Annotation, Automated Annotation; Types of Annotation: Classification, Bounding Boxes, 

Segmentation, Transcription, Named Entity Recognition (NER) 

Data Cleaning and Preprocessing: Importance of data cleaning; Understanding “Dirty” Data: 

Missing Values, Duplicates, Incorrect Formats, Outliers, Noise; Steps in Data Cleaning: Identify 

Issues, Handle Errors (Imputation, Removal), Validate Cleaned Data 

Data Splitting: Splitting data into training set and test set. 

Data Transformation Techniques: Normalization, Transformation, Feature Engineering 

(Conceptual) 

 

Unit 4. AI-Powered No-Code Development: Vibe Coding and Workflow Automation 

Vibe Coding: Concept & Workflow: What is Vibe Coding and how it works; Comparison: Vibe 

Coding vs. traditional programming; Tools Overview: Google AI Studio, Firebase Studio, Replit, 

Cursor, Windsurf (for demonstration and practice only); Tool Selection: Choosing the right 

platform for your needs; Benefits & Challenges: Advantages and limitations of Vibe Coding; 

Paradigm Shift: From code-centric to prompt-driven development; Prompt Crafting: Structure and 

examples of effective app prompts.  

 

Workflow Automation using AI: Fundamentals: What is workflow automation and its relevance 

in the AI era; Real-world Applications: Auto-email responses, Feedback summarization, Social 

media alerts & analytics; Toolset Overview: Zapier, Power Automate, n8n, Lindy and other similar 

tools (for demonstration and practice only); Choosing the Right Tool: Features, use cases, and 

integration potential. 



 

Unit 5. AI in Networks, Cybersecurity, and Forensics 

AI in Networking: Need of AI in Network Management, How AI works in Traffic Prediction & 

Intrusion Detection, Uses of AI in Optimization, Fault Management, and Routing 

AI in Cyber Security: Need of AI in Cyber Security, How AI works in Cyber Security, Uses of 

AI in Cyber Security, Challenges and Considerations of AI in Cyber Security 

AI in Digital Forensics: How AI enhance digital forensic investigations, Role of AI in cyber-

forensic evidence acquisition and analysis, Overcoming challenges and limitations of AI in 

forensics, The future outlook for AI-powered forensic tools 

 

 

 

 

 

 

 

 

 

 

 

 

 



APPLICABLE TO COMPUTER SCIENCE, DATA SCIENCE, ARTIFICIAL 

INTELLIGENCE, COGNITIVE SYSTEMS, DATA ANALYTICS, CLOUD 

COMPUTING, CYBER SECURITY AND ANY OTHER COMPUTER SCIENCE 

ALLIED STREAMS 

SEMESTER-II 

COURSE 1: APPLICATIONS OF ARTIFICIAL INTELLIGENCE 

Practical                                             Credits: 1                                          2 hrs/week  

Suggested Lab Practicals (No Coding) 

Lab 1 - Exploring Public Datasets (Orange Data Mining) 

● Visit a public repository (Kaggle, UCI, data.gov.in) 

● Download a dataset (e.g., rainfall data, literacy rates, or traffic accident statistics) 

● Procedure: 

1. Open Orange → Add File widget → Load a CSV (e.g., Titanic dataset). 

2. Connect to Data Table → View rows/columns. 

3. Connect to Data Info → Check attributes, data types. 

4. View in Data Table and Distributions widget. 

● Observation: Note numeric, categorical, missing values. 

● Outcome: Students understand structured data format in CSV. 

 

Lab 2 – Exploring Cybersecurity Datasets (Orange Data Mining) 

● Dataset: Kaggle Cybersecurity dataset. 

https://www.kaggle.com/datasets/teamincribo/cyber-security-

attacks?select=cybersecurity_attacks.csv 

● Procedure: 

1. Load dataset into Orange (File widget). 

2. View using Data Table and Distributions widgets. 

3. Identify numerical (packet size, duration) and categorical (protocol type, attack 

type) attributes. 

● Observation: Note features that indicate “attack” vs. “normal traffic.” 

● Outcome: Students understand the type of features used in intrusion detection. 

https://www.kaggle.com/datasets/teamincribo/cyber-security-attacks?select=cybersecurity_attacks.csv
https://www.kaggle.com/datasets/teamincribo/cyber-security-attacks?select=cybersecurity_attacks.csv


 

Lab 3 - Understanding Dataset Metadata and Formats 

● Take two datasets in different formats (CSV, JSON) 

● View metadata (description, features, size, license) 

● Compare domain-specific datasets (e.g., medical vs. finance) 

  

Lab 4 - Data Annotation Exercise 

● Use MakeSense.ai or VGG Image Annotator (VIA) 

● Annotate 10 sample images (traffic signs, fruits, or medical scans) 

● Export annotations in XML or YOLO format 

● Discuss annotation errors and challenges 

  

Lab 5 - Data Cleaning and Visualization (Orange Data Mining) 

● Aim: To clean dirty data and visualize categorical and numeric attributes. 

● Procedure: 

1. Load dataset. 

2. Connect File → Edit Domain (to change types) and Impute (to fill missing values). 

3. Compare cleaned vs. original in Data Table. 

4. Distributions widget. 

5. Check various features distribution. 

(Optional: Create simple bar charts/line charts to visualize trends using Google Looker 

Studio) 

● Observation: Missing values filled with mean/median., Graphical representation of data. 

● Outcome: Learn importance of data cleaning., Students learn importance of visualization 

in preprocessing. 

  

Lab 6: Train/Test Split in Orange 

● Aim: To split dataset for AI training/testing. 

● Procedure: 

1. Load Titanic dataset. 

2. Connect File → Data Sampler (70% train, 30% test). 



3. Connect outputs to Data Table widgets to view. 

● Observation: Students see two different subsets. 

● Outcome: Concept of model validation using split data. 

 

Lab 7 – Writing a Detailed Prompt for a Simple Game App (Generative AI) 

● Objective: Understand prompt engineering by designing a game idea. 

● Activity: 

1. Open ChatGPT (or Gemini, Copilot). 

2. Write a detailed prompt like “Create a simple text-based treasure hunt game with 

levels, scoring, and random challenges.” 

3. Ask the AI to refine game rules, scoring, and characters. 

4. Document how prompt detail changes the AI’s response. 

● Outcome: Students learn how detailed prompts shape AI outputs. 

 

Lab 8 – Create a Portfolio Website using Vibe Coding Tool 

● Objective: Learn how AI-assisted coding tools can automatically generate websites from 

simple instructions. 

● Activity: 

1. Open Vibe Coding Tool (Windsurf/Cursor/Firebase Studio/Any other vibe 

coding tool). 

2. Give a natural language instruction: 

 “Create a personal portfolio website for a Computer Science student. It should 

have sections: About Me, Education, Skills, Projects, and Contact.” 

3. Experiment with different prompts to change layout, theme, or color scheme 

(e.g., “Make it a modern dark theme with blue highlights.”). 

4. Preview the generated site and customize content. 

● Outcome: Students experience how AI converts prompts into functional websites with 

minimal coding effort. 

 

 

 



Lab 9 – Develop an Interactive Education Quiz App using Vibe Coding Tool 

● Objective: Understand AI’s role in creating educational applications. 

● Activity: 

1. Open Vibe Coding Tool. 

2. Give prompt: 

 “Build an interactive quiz app for students with multiple-choice questions on AI 

basics. Include features: Start Quiz, Show Score, Retry.” 

3. Refine the app by asking AI to: 

■ Add timer for each question. 

■ Show correct/incorrect answers instantly. 

■ Add a Leaderboard page. 

4. Test the app by playing the quiz. 

● Outcome: Students see how AI-generated apps can support e-learning and assessments. 

 

Lab 10-Automating Feedback Summarization using n8n and AI 

Objective: Automatically summarize student feedback responses using AI and email the summary 

to the teacher. 

Steps: 

1. Trigger Node: Google Sheets (watch new row for feedback). 

2. AI Node: Send text to OpenAI/Gemini API for summarization. 

(Get a free API from OpenRouter (https://openrouter.ai/) → Gives free trial credits + 

access to multiple models.) 

3. Action Node: Gmail → email summarized feedback to teacher. 

4. Test: Enter sample feedback in Google Sheet → receive AI summary via email. 

5. Discussion: How AI reduced manual effort in reading every response. 

Outcome: Students see how automation + AI can transform data into insights instantly. 

Lab 11 – Using AI Functions in Google Sheets 

Objective: Enable students to experience Google Sheets’ built-in AI-powered features like 

summarizing, categorizing, sentiment analysis, and text generation through simple prompts within 

the spreadsheet environment. 



Tools & Setup 

Enable Google Sheets with Workspace Labs  

https://workspace.google.com/labs-sign-up/u/1/ 

Follow the References and experiment with summarizing, categorizing, sentiment analysis, and 

text generation using =AI() function 

https://support.google.com/docs/answer/15820999?visit_id=638919819014625788-

1742465261&p=ai-function&rd=1 

https://support.google.com/docs/answer/13447609?hl=en&sjid=9077695331310534831-NC 

https://support.google.com/docs/answer/13635180?hl=en&ref_topic=13450085&sjid=90776953

31310534831-NC 

Outcome: Students will experience various AI functions within a spreadsheet-text generation, 

summarization, categorization, sentiment analysis. 

 

Lab 12- Deep Fake Image Detection 

Objective 

Enable students to critically assess image authenticity using multiple free AI tools, understanding 

the strengths and limitations of each. 

Tools: 

Deepfake-O-Meter: https://zinc.cse.buffalo.edu/ubmdfl/deep-o-meter/landing_page 

Decopy AI Image Detector: https://decopy.ai/ai-image-detector/ 

Procedure 

1. Collect Images 

○ 2 real images (e.g., faces from Unsplash or personal photos) 

○ 2 AI-generated or manipulated images (e.g., from Midjourney, DALL·E, or 

Google AI studio) 

2. Run through DeepFake-o-Meter 

○ Visit the platform and upload an image. 

○ Note the output: what algorithms flag or overall score for authenticity. 

3. Use Decopy AI Image Detector 

○ Upload the same images. 

○ Check results indicating whether the image appears AI-generated. 

https://workspace.google.com/labs-sign-up/u/1/
https://support.google.com/docs/answer/15820999?visit_id=638919819014625788-1742465261&p=ai-function&rd=1
https://support.google.com/docs/answer/15820999?visit_id=638919819014625788-1742465261&p=ai-function&rd=1
https://support.google.com/docs/answer/13447609?hl=en&sjid=9077695331310534831-NC
https://support.google.com/docs/answer/13635180?hl=en&ref_topic=13450085&sjid=9077695331310534831-NC
https://support.google.com/docs/answer/13635180?hl=en&ref_topic=13450085&sjid=9077695331310534831-NC
https://zinc.cse.buffalo.edu/ubmdfl/deep-o-meter/landing_page
https://decopy.ai/ai-image-detector/


Observation: How AI tools help in Digital Forensics. 

 

Note: The Tools suggested above are tentative. Teacher/Student is free to choose any other 

similar tool to execute the said lab experiments. 

 

Books/References 

1. Data Science for Beginners, Andrew Park 

(Introductory concepts of data types, collection, cleaning, and visualization without 

coding) 

2. AI Basics for Non-Programmers, Tom Taulli 

(Clear explanations of AI data lifecycle and real-world use cases) 

3. Data Preparation for Machine Learning, Jason Brownlee 

(Conceptual understanding of dataset quality, preprocessing, and pipelines) 

4. Hands-On Data Science for Non-Programmers, David Meerman Scott 

 (Spreadsheet-based data exploration and visualization) 

5. You Look Like a Thing and I Love You – Janelle Shane 

6. Vibe coding: https://cloud.google.com/discover/what-is-vibe-coding 

https://www.ibm.com/think/topics/vibe-coding 

https://firebase.google.com/docs/studio/prompting 

7. Workflow Automation: https://www.ibm.com/think/topics/workflow-automation 

https://www.ibm.com/think/topics/ai-workflow 

https://n8n.io/ 

8. AI in Cyber Security: https://www.geeksforgeeks.org/ethical-hacking/ai-in-cybersecurity/ 

9. AI in Networks: 

https://www.cisco.com/site/us/en/learn/topics/artificial-intelligence/what-is-ai-in-

networking.html 

10. AI in Digital Forensics: 

https://www.eccouncil.org/cybersecurity-exchange/cyber-talks/ai-and-ml-in-digital-

forensics-the-future-of-forensic-investigations/ 

 

https://cloud.google.com/discover/what-is-vibe-coding
https://www.ibm.com/think/topics/vibe-coding
https://firebase.google.com/docs/studio/prompting
https://www.ibm.com/think/topics/workflow-automation
https://www.ibm.com/think/topics/ai-workflow
https://n8n.io/
https://www.geeksforgeeks.org/ethical-hacking/ai-in-cybersecurity/
https://www.cisco.com/site/us/en/learn/topics/artificial-intelligence/what-is-ai-in-networking.html
https://www.cisco.com/site/us/en/learn/topics/artificial-intelligence/what-is-ai-in-networking.html
https://www.eccouncil.org/cybersecurity-exchange/cyber-talks/ai-and-ml-in-digital-forensics-the-future-of-forensic-investigations/
https://www.eccouncil.org/cybersecurity-exchange/cyber-talks/ai-and-ml-in-digital-forensics-the-future-of-forensic-investigations/

